Linux – Problem mounting LVM in ubuntu

linuxlvmmountUbuntu

A few months ago I have setup a server with three hard disks. The partition mapping the disks as follows:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7ca36fee

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       12158    97659103+  83  Linux
/dev/sda2           12159       13131     7815622+  82  Linux swap / Solaris
/dev/sda3           13132      121601   871285275    5  Extended
/dev/sda5           13132      121601   871285243+  8e  Linux LVM

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000160d1

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1      121601   976760001    5  Extended
/dev/sdc5               1      121601   976759969+  8e  Linux LVM

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0008d423

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1      121601   976760001    5  Extended
/dev/sdb5               1      121601   976759969+  8e  Linux LVM

As you can see I have created a Linux LVM file system.
This are the information of the LVM Logical volume:

--- Logical volume ---
LV Name                /dev/gegevens/Data
VG Name                gegevens
LV UUID                XsddGq-i3wO-HjTg-Lafe-TSF3-28kr-FGYhRd
LV Write Access        read/write
LV Status              available
# open                 1
LV Size                2.63 TB
Current LE             689648
Segments               3
Allocation             inherit
Read ahead sectors     auto
- currently set to     256
Block device           252:0

Now I have the following problem the LVM file system don't mount properly.

If I open the mount point I see only a few files of the LVM disk. If I want to unmount the disk I get the following error:

umount /data/
umount: /data/: not mounted

If I want to mount the volume I get the following error:

mount -a
mount: /dev/mapper/gegevens-Data already mounted or /data busy

Wat is the problem here?

Thank you,

Ivo Trompert

Best Answer

Please paste the output of the following commands:

mount

as root:

lsof | grep gegevens-Data

as root again:

lsof | grep /data