Linux – Set default system audio output port (for all accounts)

audiolinuxpulse-audioUbuntuubuntu-10.04

The default output audio port Ubuntu doesn't work on my system. It should be "Analog Mono Output/Amplifier", instead of "Analog Output/Amplifier". I can easily change that in sound preferences, just by choosing the right port in the "Output" tab. The problem is this would only apply to a single account, and I would like to change it system-wide, so it applies to all accounts on the system (I have more than 100 users…).

I'm after 2 hours of Googling, so any help would be appreciated.

Update: I can achieve the same effect as I would by changing it in sound preferences using the following command:

pacmd 'set-sink-port' 'alsa_output.pci-0000_00_1f.5.analog-stereo analog-output-mono;output-amplifier-on'

Unfortunately that's still not system-wide, so doesn't help me much…

Best Answer

I guess you need to set default-sink in pulse-client.conf, see man pulse-client.conf but I didn't test that.