Linux – Trouble mounting NTFS disk on Linux


I'm trying to mount an NTFS disk on Linux Mint.
It seems windows wasn't done with this volume before it was turned off. Is there a way to fix this error without putting my drive in a windows machine?

Here is the error message

Error mounting /dev/sdb2 at /media/cobolt/Legalise it: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb2" "/media/cobolt/Legalise it"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Best Answer

According to the ntfs-3g man page, there is an option that allows you to do this:

          Unlike  in  case  of  read-only  mount,  the read-write mount is
          denied if the NTFS volume is hibernated.  One  needs  either  to
          resume  Windows  and  shutdown  it  properly, or use this option
          which will remove the Windows  hibernation  file.  Please  note,
          this  means  that  the  saved Windows session will be completely
          lost. Use this option under your own responsibility.

So, I stress that this will destroy any unsaved data that is in the hibernated Windows session. If that is not an issue for you, you should be able to access the drive by running (why in the world do you have a space in your mount point?):

sudo ntfs-3g -o remove_hiberfile /dev/sdb2 /media/cobolt/Legalise\ it/

That should mount the drive correctly and since it will delete the hibernated session file, it should mount normally from now on.

Related Question