Linux – Unable to login Root account in BOSS Linux

linuxpasswordsrootsshuser-accounts

I use EduBOSS_Linux 3.0.
I want to Login my BOSS Linux with root account.
I try combination of default password
root —- root
boss —- root
root —- boss
boss —- boss

root —- root is working for got root privilege during software installation but that username and password combination not work for login root account.
1) Why accurate username and password also not able to login in root account.
2) How can I login in root account of Boss Linux?
3) How can change password of root account of BOSS Linux by Admin Account?
I post screen shot here
I Upload images here with description and details

Best Answer

Chances are... There's intentionally no root password. You're supposed to use sudo as needed. THIS IS A GOOD THING. It means that you're less likely to do the wrong thing as root, is more secure and sudo let's you do all the same things anyway.

If you must, sudo su (with a user who can sudo, typically the first user you add during install) will let you do things as root, including setting a root password. You don't need to /shouldn't

From the additional information in the comments, you're running a modern version of gnome, and gdm. I don't use gnome, but with that information, and that BOSS is a debian derivative, we can find an answer.

Many distros including debian, which BOSS is based off of disable root logins for graphical logins. This is a very sensible thing (and in the old days, KDE would have a red background and a bomb symbol when you did this). Once again, this is a terrible idea and you should generally not run anything as root. There's usually something that emulates sudo (gksudo?). Alternately you need to open up your login manager config file, and comment out the line that disallows root logins. I re-iterate this is a terrible idea, and you probably should not do it.

Have I said a few times its a bad idea? Good.

If you still want to do this its a file called /etc/pam.d/gdm3 and you need to comment a line out that says #auth required pam_succeed_if.so user != root quiet_success. My source suggests that you use vi, but any text editor should work