Linux – Why is the USB drive not mounted during startup

arch linuxfstablinuxmountraspberry pi

I have Arch Linux running on my Raspberry Pi. I added the following line to my fstab file:

/dev/sda1    /mnt/MyBook    ntfs    defaults    0    0

for a while this worked fine, the device was mounted automatically at startup. I installed transmission-cli and was downloading some stuff when the Pi seemed to die. I turned it off and on again and noticed the drive wasn't mounted. If I run sudo mount -a the drive will be mounted again just fine, but why is it not doing this at startup anymore?

Best Answer

One possible explanation is the 'defaults' option was changed to use 'noauto' for your ntfs partition. (Is there a tunefs for ntfs?)

Another (more likely) explanation is with boot order and boot timing: the module for the USB stack may perhaps be loaded after the fstab boot-time mounts are attempted; or the USB device doesn't respond fast enough for the kernel, so boot proceeds before it's ready.

There's no resolution in this linked discussion, but see: https://bbs.archlinux.org/viewtopic.php?id=79676 - moving the mount to rc.local may help you. (As well as specifying a delay in rc.local.) Considering the RasPi isn't the fastest ship in the pond I'd lean towards this being a timing issue.