Linux – XFCE Login Error: Unable to Load Failsafe Session

arch linuxxdgxfcexfce4

I'm having a problem logging into xfce under Arch Linux.

After logging in (with Slim like I usually do), I get this error message:

Unable to load a failsafe session
Unable to determine failsafe session name. Possible causes xconfd isn't running (D-Bus setup problem);
environment variable $XDG_CONFIG_DIRS is set incorrectly (must include "/etc") or xfce4-session is installed incorrectly.

Fixes that did NOT work:
I found these fixes on Google, but none of them worked for me.
1. Make sure $XDG_CONFIG_DIRS is set correctly:

export XDG_CONFIG_DIRS=/etc/xdg

2. Make sure everything in my home directory has correct permissions:

sudo chown -R $USER $HOME

3. Change permissions of /etc/xdg:
(I later realized that this must be an old fix because Arch recommends 755 permissions for /etc/xdg, NOT 644)

sudo chmod 644 /etc/xdg

4. Try to start an xfce session manually:
(because this did not work, I know that the problem is with xfce and not SLIM)


5. Total reinstall of all xfce apps:

yaourt -Sa $(yaourt -Qsq xfce) 

6. Remove xfce config and then reinstall everything (in order to make sure that xfce settings are reset to default)

mv ~/.config/xfce ~/.config/xfce.bak
yaourt -Sa $(yaourt -Qsq xfce)

7. Deleting session cache:

rm -r ~/.cache/sessions/

I'd list the output of yaourt -Qsq xfce if I could, but I'd need to login to my computer in order to copy and paste it.

Best Answer

The way work for me is to replace exec startxfce 4 by dbus-launch xfce4-session

The xstartup file looks like the following:

 dbus-launch xfce4-session
Related Question