Linux – Yum repo with python 2.6 on Centos7

centoslinuxnode.jspythonyum

I need to run Nodejs 4 on a CentOS 7 machine. I have a limited internet access on this machine and basically can only hit Yum repositories (I can add new ones).
Since Nodejs 4 is not available even in EPEL, I am using a private Yum repo with Nodejs 4 wrapped in an RPM. I have not created this RPM and can't change it.
The problem is – the mentioned Nodejs 4 RPM has indirect dependency on Python 2.6 exactly (indirect as dependency of dependency needs this version of Python). Now Python 2.6 is not available in any Centos 7 yum repo (not even in EPEL), the only versions available to me are: 2.7.5 and 3.4.3. And Thus the installation of the said Nodejs 4 RPM fails:

Error: Package: nodejs4-runtime-4.4.2-22.el6.x86_64 (nodejs4)
       Requires: python(abi) = 2.6
       Installed: python-2.7.5-34.el7.x86_64 (@bertinet-base-7)
           python(abi) = 2.7
           python(abi) = 2.7
       Available: python34-3.4.3-4.el7.x86_64 (epel)
           python(abi) = 3.4

Like I said, I do not have internet access except for Yum repositories. Do not ask me why, it is not my decision, I can't change this.
I need Nodejs 4 on this machine.
Is there any trusted Yum repo out there for Centos 7 that provides either: Nodejs 4 or Python 2.6? Thanks.

Best Answer

nodejs4-runtime-4.4.2-22.el6.x86_64 - installing package for EL6 on EL7 will not work.

Get a package for el7 for example from here however this may conflict with nodejs from other sources.

The instructions on node site are clear enough.

Anyway this looks like a duplicate of https://stackoverflow.com/questions/32561962/install-nodejs-4-on-redhat