Mac – How to fix EFI-boot on the Macbook Pro after Ubuntu install

bootefimacbook pro

The MacBook does not boot. The screen stays blank (black) – not the grey, active screen like normal. To power off, I hold the power button down.

After 5 boot attempts the MacBook finally shows the grey, active screen and boots OSX.

This started after I installed Ubuntu 11.04 on a 2nd partition.


Here is the sequence of events and my attempts to fix the problem:

  1. OS X on partition 1.
  2. rEFIt installed and set to appear on every boot – everything still working fine.
  3. Installed Ubuntu 11.04 on partition 2 – at the end it said Grub was installing on the hard-drive.
  4. MacBook, after shutdown, and restart sounds a long tone and has a blank (black), unlit screen (ie not grey/active). It does not boot or do anything. Holding Option key does not work. After 5 power cycles, the MacBook finally boots to OSX.
  5. I synced the partition table with rEFIt and shutdown.
  6. Same as step 4, after many reboots I can load rEFIt then OS X or Ubuntu.
  7. I ran rEFIt enable-always.sh script to bless it again – result same as 4.
  8. I used OS X's Startup Disk utility to select OSX hard-drive – result same as 4.
  9. I then used OS X install-DVD to totally format hard-drive and re-installed OS X – result same as 4.
  10. Many more attempts of steps 5 to 9 – result same as 4.

Further details on number 4 (above):

Note, Option (AKA Alt) key works on a normal bootup, but it is after/outside my problem.

A "normal boot" can be described as:

  • OSX loads
  • or, holding Option key shows the EFI boot-selection
  • or, holding Command+Option+P+R keys resets NVRAM.

However, the problem I have is that "normal boot" fails for the first 5 power-cycles. (After a failed boot, I can kill power by holding the power-button down.) During failed boots, NOTHING works (no keys, no OSX) – just a blank screen.

Its like the EFI code crashes or freezes. But on the 5th power-cycle a "normal boot" always works, like some fail-safe is triggered. Then after I shutdown OSX, the boot issue repeats – ie another 5 power-cycles before I can get back to OSX.

Note, on the first (only the first) failed boot (one of five) (after shutdown) the MacBook Pro makes a tone (an error-tone I assume).


Here is my system:

  • Model Name: MacBook Pro
  • Model Identifier: MacBookPro5,4
  • Processor Name: Intel Core 2 Duo
  • Processor Speed: 2.53 GHz
  • Bus Speed: 1.07 GHz
  • Boot ROM Version: MBP53.00AC.B03
  • SMC Version (system): 1.49f2

Best Answer

Try resetting the NVRAM and PRAM. See this Apple Support link.

It could also be a problem with the boot loader; try pressing Alt at boot time and select the OS X partition. If it boots directly w/o any problems you need to check on the boot loader.

For further information about Ubuntu on a MacBook you could also consider reading Installing Ubuntu on a MacBook.

Related Question