Windows – MacBookPro running Windows 7: accidental trackpad input is driving me mad

boot-campinputmactouchpadwindows 7

I am running Windows7 Professional 64bit on a 2010 MacBookPro using BootCamp 3.1.
I am using an external trackball.
When I am typing, I accidently brushing the trackpad and accidently overtyping randomly selected pieces of text. Which is driving me mad.

I have tried to install TrackPad++, but I could not get the Trackpad++ control panel to recognise that the driver software was installed.

I tried TrackPad Magic, but although it gives me a system tray icon telling me it is working, but it does not appear to disable the track pad.

A quick Google implies that there should be an option in the BootCamp Control Panel 'Ignore accidental Input while typing'.
But I can't see one of those in my BootCamp Control Panel.

Am I looking in the wrong place? Is this feature 32bit only?
Is there anything else I should try?

Best Answer

  • Here's what I did. Open Device Manager (Click Windows, then type in Search programs and files: device manager)

    Go to Mice and other pointing devices, you will see you have two HID-compliant mouse. Those are your mouses/trackpads/trackballs. Disable each one of them, check which one is your built-in trackpad or external trackball

    If you accidentally disabled your external trackball, navigate the mouse pointer using the built-in trackpad, then re-enable the one(external trackball) you mistakenly disabled. Then disable the other one