Macos – How to make non-anti-aliased text look good in Firefox on Mac OS X

anti-aliasingfirefoxfontsmacmacos

After being a Windows user for the last 10 years, I got a MacBook Pro, which I'm working on configuring to my liking.

I find small-size anti-aliased text to be blurry and hard to read, so I typically disable it. I've found the settings in the General Control Panel, and used TinkerTool to increase the anti-alias threshold size to 18pt. Mac OS X and other applications appear to respect these settings.

A problem appears when I use Firefox. By default, it's configured to ignore the Mac OS anti-alias settings. This is changed by going to about:config, and setting gfx.use_text_smoothing_setting = true (default is false). However, even with this setting, it appears Firefox is still rendering the fonts under the assumption that they will be anti-aliased, which results in very odd and uneven spacing, as you can see in this example (pay attention to the placement of the "s" in "Disable"):

With anti-aliasing:

enter image description here

Without anti-aliasing:

Without anti-aliasing

How can I configure Firefox to both not use anti-aliasing and to use correct font spacing?

I'm using Mac OS X Lion and Firefox 5.

Best Answer

My system is ancient, but go to System Preferences -> Appearance-> Turn off text smoothing for font sizes [choose from the pop-up menu down at the bottom] and smaller... works for me.