Macos – System Proxy Settings not working after updating to El Capitan(10.11.1)

internet connectionmacososx-el-capitanPROXYproxy-server

I am usually using internet through proxy and it was working great with Yosemite 10.10.5.

But yesterday I have updated OS to El Capitan 10.11.1 and now same proxy settings are not working anymore.

Strange thing is that its working only in Firefox, but in Firefox we have provided Proxy settings externally (I am not using System proxy settings in that).

Can any one please help me in this, I have tried many proxy application as well but its no help (such as Proxifier, Charlesproxy, Authoxy, Proxycap, Spotflux).

I am not getting any error, Only looks like my Mac is not connected with internet, But it is as its display connected state in Network setting for Ethernet, also proxy is working in Firefox if i set its proxy settings there.

Also my office has another 10 mac, in which 2 mac has 10.11.1, and other has 10.10.5. And only 10.11.1 Mac doe not able to connect with Proxy (works in Firefox again), have contact Apple but they are also not sure whats the issue.

Here is the screenshot for my Settings, Sorry for blur, cant disclose all settings ;).

enter image description here

enter image description here

And here is the screenshot of firefox, where i have added same proxy setting, and in firefox its working,

enter image description here

Also as i said, same settings work other 8 Mac which has Yoshemity.

Update
I am checking some tutorial on ATS.
And is it possible that it is due to ATS?

@Everett, here is the image you have asked,
Also safari display this message immediately, not waiting for anything.

enter image description here

Best Answer

Got the issue solved from this link.

Advanced TCP/IP settings Set up some network services to use IPv6 addresses instead of IPv4 addresses. See Adjust advanced TCP/IP settings.

Till now we are only using IPV4, but when I have setup IPv6 then it's working.

Now it looks like this:

enter image description here