Windows – Microsoft IME + Japanese: Force Hiragana input by default

imejapanesewindows 7

I am using Windows XP SP3 and Windows 7. On both machines, I cannot make Hiragana the default input method. Is there a way to do this?

In the IME tool bar, there is the option to set the "Input Mode." This is always defaulted to "Direct Input." I would like to default to Hirgana or Katakana. I have found the setting dialog for this, by right clicking on the IME toolbar -> settings -> Japanese IME Standard -> Properties -> Default Input Mode. This setting seems to have no effect, no matter the combination of selections in the dialogs.

Is there a way to reliably set the default Input Mode?

Best Answer

Unfortunately, there is still no way to do this in Microsoft IME. Instead, Microsoft support suggests that you can use the hotkeys to switch between input modes quickly:

  • Press Alt + Shift to change the input language
  • Press Ctrl + Caps Lock to change to Hiragana
  • Press Alt + Caps Lock to change to Katakana
  • Press Alt + ~ to toggle between alphanumeric and kana modes

As a side note: if you were really intent on making Hiragana your default input, you could write an AutoHotkey script to do this for you. However, this involves understanding that scripting language.