Linux – Missing glyphs in Terminus font, how to setup a fallback font

fontconfiglinuxxterm

Most of my work happens in a terminal, so I need a clear, readable font. I've settled a while ago on Terminus (http://sourceforge.net/projects/terminus-font/), which works wonders for me.

I added XTerm*faceName : Terminus in my ~/.Xdefaults, and I do get the Terminus font. Unfortunately, a lot of Unicode glyphs are missing (mathematical symbols, greek and hebrew letters), displaying as little square blocks instead.

If I remove the faceName entry, the default configuration seems able to display most of the glyphs (including math, greek, hebrew, runic, and whatever else), but the default font is much harder to read.

A google search hints that it should be possible to use Terminus as the default font, and fallback to (an)other one(s) for missing glyphs, but provides no further explanation. I've seen documentation that recommends Bitstream Vera Sans as a fallback, but it lacks the glyphs I need too; I don't know how to identify the default font used by xterm either, I had a look at /usr/share/X11/app-defaults/XTerm, but all I can find are generic references to old pre-fontconfig font names.

Using Gentoo Linux, fontconfig and xterm are up to date, USEs trutype and unicode enabled, X.Org server 1.6.

Edit: I alternate between Ratpoison, Awesome and XMonad, without a desktop environment.

Best Answer

  • xterm is not a friend to fontconfig. Consider using something like Terminal instead.

  • Related Question