Windows – Move folders to Library and they disappeared (permissions)

librariespermissionswindows 7windows-explorer

Windows 7 Professional

I had a large number of files in a folder. I moved these files (selected and dragged them in Windows Explorer) to the users Documents Library (I meant to get their My Documents folder but had accidentally opened the library location instead). The files/folders never appeared in the library but disappeared from the original location. I tried using the "Undo" feature of explorer to restore the files and they did not return. When I go to the library properties, the library contains a the user's redirected network share \server\volume\username\documents with the words "Default Save Location" and then on the next line "Unsupported" next to the redirect.

Where did the files go and is there any way to get them back?

Best Answer

The way the libraries work, they are not meant to be used directly as folders in the way you used them, but rather are composites of whatever folder(s) you associate with that type of library. So you should never move files directly to a library; rather, add the folder location to the library, to have the files appear there.

Along with the ability to show the files from more than one folder (i.e. the Documents library could show files from C:\DOCS, D:\DOCUMENTS, etc.) the libraries are oriented around the content type. So the Documents library is, by default, defined to show only what Windows thinks are document files. Often it won't even show PDFs, nor exes, pictures, etc.

However, since you probably haven't changed the default library settings, you can still get to the files that you moved there. The default location for the Documents library is My Documents. So if you open the My Documents folder directly, you will likely find the files that you moved.

If they're not in the My Documents folder, they are likely in the "\server\volume\username\documents" location; again, open that folder directly, not through the Library.

Last, if still not found, the documents may be stored in the hidden Libraries folder, which is at C:\Users(User-Name)\AppData\Roaming\Microsoft\Windows\Libraries.

You may also want to right click on the Documents library folder, choose Properties, and then change the "optimize" setting to "general".