Windows – Need to disable/enable WiFi adaptor on every startup to make it work

driverswindows 10wireless-networking

I've just done a clean install of Windows 10 on an old laptop (Lenovo E320), with an Intel Wireless N-1000 network adaptor. Every time the computer starts up, the WiFi won't connect, and when I check the device properties it has a "Device Cannot Start (Code 10)" error.

To fix this, all I have to do is go to the "Driver" tab and disable/enable the device, and the Wifi connects instantly and is rock solid. But I have to do this everysingletime I start the computer, and it's driving me insane.

I've tried everything I can think of, uninstalled and re-installed drivers for the device in question (multiple different versions), power management devices/settings/software, tried various bloatware from Intel and Lenovo, completely re-installed the OS, nothing works.

Some very old forum posts suggested it may have something to do with UEFI/Legacy BIOS settings, but that's a bit beyond me unfortunately. The laptop also has a WiFi on/off function key which I've noticed doesn't work. I think this may be connected but I've been unable to get the function key working either.

Any suggestions on how to fix this would be appreciated. At this point I'd be happy enough if I could have some sort of script run on startup that disabled/enabled the WiFi for me.

Best Answer

  • Sorry I am reviving an old thread, I found a solution to this problem, and others like me who google and find this thread might like to know how I fixed mine.

    I went into the adaptor settings and then into configure on the "Connect using" option. This brings up the wireless network device settings. From there you can choose power management and deselect "allow the computer to turn off this device to save power" After this it resolved the issue on two different laptops for me. This was on both an MSI GS70 stealth and a Microsoft Surface 3

  • Related Question