Linux – Netflix on Firefox Linux: “EME has been preffed off”

drmfedorafirefoxlinuxnetflix

I'm trying to watch Netflix on Firefox 53.0 (Fedora 24).

When I try to watch any video, I get the following error message:

CREATE: Request mediaKeySystem access rejected: EME has been preffed off

enter image description here

Best Answer

  • Accoridng to the Netflix support pages (and I tested and confirmed it on my computer), in order for Firefox to be able to play Netflix video, you need to:

    • Enable playback of HTML5 DRM media in Firefox. To do that, type about:preferences#content on the addres bar, and check "Play DRM Content".

    • Try to watch the DRM-protected Netflix video again.

    • Wait for Firefox to automatically install the "Widevine Content Decryption Module provided by Google, Inc" plugin (Firefox will automatically install it when you first try to watch any Netflix video).

    • A dialog similar to the one below is displayed, just click "yes": enter image description here

    • you can check that it is installed by visiting about:addons and clicking "plugins", there will be an entry named "Widevine Content Decryption Module provided by Google, Inc"

  • Related Question