Networking – Accessing router from another router/modem


I have a Wi-Fi router connected to my Wi-Fi modem through a LAN cable. I have designated a static IP address to the router inside the modem configuration.

Therefore the IPs are:

  • Modem:
  • Router:
    • – external IP address as assigned by modem.
    • – internal IP address.
    • Both have subnet mask.

DHCP is enabled both on router and modem but with different subnets.

The main PC is connected to my modem and the rest of the home network connected to my router.

The problem is I can't access my router (i.e. configuration window & router's clients) through my main PC, neither by or nor or any router's client address.

I can access my modem's config window from the clients of router, but not the other way around.

The following may help you understand my setup:

network scheme

To be exact, I am using an ADSL modem but it can be configured to 3 modes:

  1. ADSL Modem Router Mode.
  2. 3G Router Mode.
  3. Wireless Router Mode (which I'm using) – one of the LAN port can be configured to be used as WAN port.

The main task I am trying to accomplish is to access config window of router from modem's clients and share files b/w the main computer connected to the modem and 2nd router's clients i.e. Raspberry Pi, other machines etc.

P.S. I can access/share my files fine in LAN to LAN configuration and disabling DHCP on second router, but still can't access config window of router through any of the clients (whether connected to modem or router). Isn't this using router as a switch?

Please note that I want to share files and access config windows of both modem and router in LAN to WAN configuration.

Best Answer

So the first problem I saw was it seems you have the definitions of external and internal IPs confused. But that shouldn't keep us from helping you. :)

So First off, you cannot access your router through your modem by using as this is assigned to the router by itself. The clients will be able to access it in this way, but not the modem, or anything connected to the modem, because it doesn't have a DHCP entry with that address.

That aside, the reason you might not see the configuration screen for your router is because the port is locked down. As far as the router knows, your computer is a random computer from the internet, as such the firewall blocks most ports from connecting. It could also be that your port 80 is being used by a different service.

In any case, the only way to access your router would be to open port 80 in port forwarding settings and have it point to (in router settings). This should do what you want. Here is a quick guide.

  • Open your router's configuration
  • Click Advanced Settings on the left hand side
  • Click NAT
  • Click the Add button
  • Select the Custom Service radio button
  • In the Name field type something like Router Config
  • Enter as the server IP.
  • For all External and Internal port fields type 80.
  • Click apply and save.

Just note, I was unable to find the exact model you specified as your router. So the settings or names may change. Regardless you are looking for NAT or Virtual servers as a setting option. Most of the values should be the same from there.

You should now be able to access your router from your desktop connected to the modem. (If not try restarting the router)


The method above should allow you to see the configuration screen from the clients of the modem. If NAT is unavailable, you need the Virtual Server option.

So you want to share files between systems... This procedure becomes more complicated at this point...

First thing you will need is a FTP server hosted by one of your systems. You can find many a many tutorial online. For Windows, Filezilla works for a server, for Linux systems you have to be a bit more in depth.

I won't post a guide on setting one up, due to there being many ways and systems across your network. And lack of information on a potential server.

However, once you get a FTP server running on your "server" you just have to port forward it with the same method above. However changing the port from 80 to 21 (if you keep the default).

Hope this Helps!

Related Question