Networking – VPN Issue – successful connection through mobile (iPhone Hotspot) but unsuccessful through home WIFI


I need to connect from home to the office's internet network to access the different printer control panels and NAS server. Since the router we have in the office does not have the possibility to configure a VPN by default, I have configured a vpn L2TP/IPSEC on the myQNAP NAS.

The computer with which I try to connect is a Macbook pro. I configured the VPN on the mac, and tried to connect. When I'm connected to the internet via my home WIFI, despite the VPN working I can't access any IP address in the office network (such as the configuration address of the router or the address of the NAS or printer).

On the other hand, when I am connected to the Internet via Hotspot USB/4G network of my iPhone, with the same VPN activated on the macbook, I can successfully access all the addresses mentioned above.

Given the situation I imagine that the problem is not in the VPN configuration on the NAS, nor the VPN configuration on my laptop. Probably there is something that goes in conflicts when I connect via the home WIFI or in the WIFI settings of my laptop.

Could you please help me? I really need to be able to connect.

1 Router
2 Router

Best Answer

With the further information you have supplied it looks like your issue is due to your router resolving the IP to an address in you local network.

Whilst this could be handled by creating routing tables I advise changing the range of one of your routers.

Looking at the image of the second router you have attached I would advise to change to the following:

Internet-Box IP Address:
Subnet Mask:

Leave "IP address Application part" setting on "Automatic"

DHCP Range from to

You should now be able to communicate with devices through the VPN on the subnet/range.

If you have any devices on a static IP in the network that you are changing this on you will need to update them with the same range of 192.168.2.* with the following details:

IP Address: 192.168.2.X (X being a number outside of the DHCP range)
Subnet Mask: