Networking – Why the Port Forwarding rule is not working

firewallnetworkingport-forwardingrouter

I'm a total noob about TCP/IP, and try to set a port forwarding rule.

What I'm trying to do is this:

  • I have multiple computers connected to my router (zyxel p-660hw-t1 v2), one of them is working as Ubuntu Server
  • I want to connect that Ubuntu Server by entering my public IP, and a specific port. So I want to type 88.225.my.ip:26600 (is it safe?) and get served the apache homepage
  • It has apache installed, and working, when I type 192.168.1.35 from my home network. So I guess it's local IP is 192.168.1.35.

Now, I'm trying to forward port 26600 to 192.168.1.35.

These are my modem settings page. (They are in Turkish, couldn't figure out how to display in English, but you will recognize the keywords, and I'll try to explain)

1st: NAT -> Port Forwarding page :
enter image description here

2nd: Firewall -> General

The unchecked box means "Active Firewall". So the other rules are not applying anyways, right?
enter image description here

3rd: Firewall -> Rules

Activated uPnP, But I deactivated it now, it doesn't work either way..
enter image description here

4th: Advanced -> UpnP -> General
enter image description here

Can you please tell me what am I doing wrong?
And I would really appreciate it if you explain your answer, to a noob 🙂

Edit:

Or how can I identify what the problem is?

Best Answer

It seems like you cannot forward a different port than the one setup on your server. For instance, your firmware doesn't allow forwarding port 26600 of your WAN IP to port 80 of your local machine.

You might want to change the port on which Apache serves its HTTP service before enabling the port forwarding.

  1. Open /etc/apache2/httpd.conf in a text editor. Find this line:

    Listen 80
    

    Change it for:

    Listen 26600
    
  2. Restart Apache

    sudo service httpd restart
    

Follow this link to learn more on how to forward ports on your router. You will forward port 26600 to 26600 to your local IP 192.168.1.35.