Windows – No drive mounts when phone connect to computer through USB

androiddriverswindowswindows 10

The computer is a desktop PC running Windows 10 N. The phone is a Sony Xperia Z2 running CM 12.1 (and is rooted). When I connect them using a USB cable, the phone appears in the device manager but nothing shows up in my computer. I want to easily be able to transfer large files between the computer and phone without using the internet.

Connecting the phone to the computer used to work fine and I'm suspecting some software updated that broke something.

As suggested, I uninstalled the driver from Device Manager, and tried installing it again. I downloaded this zip file from the Sony website, extracted, and followed the directions of this YouTube video to install the drives: in device manager added a legacy device, chose "have a disk", and selected sa0111adb.inf. This did not work. Now there are two drivers in device manager:

two drivers

I have a Windows 7 VM that is able to connect to phone and I can access the internal memory and SD card through it. However I tried another Windows 7 VM and it did not work.

Here are the settings on the phone

screenshot from phone

I also tried different USB ports to make sure. I don't think it can be a problem with the cable, since it still works with Windows 7 VM.

Even though Windows N doesn't come with the media packages, I have already installed them and it still doesn't work.

for KB 3133719

package already installed

for KB3099229

not applicable

On the Windows 7 VM (which I can actually connect to) the driver is different than device manager.

device manager

device manager

device manager

Best Answer

I managed to solve the problem myself, but having taken advice from various sources am unsure which steps are required to fix the problem. Here is what I advise. Keep in mind this is for Cyanogenmod, not stock Android.

  1. As per David Woodword's answer, make sure the correct Windows Media Player Feature Pack's are installed: Windows 10 (build 1511) and Windows 10 Anniversary Edition (build 1607).
  2. On the phone, under settings > developer options > revoke USB debugging authorizations
  3. From XDA-developers forum "download "usb mass storage enabler" form google play" and use it.
  4. When the phone is connected to the computer through a USB cable, the notice in the status bar header appears "Connected as a media device / Touch for other USB options". Touch it and toggle the settings. For example check and uncheck MTP or change to Charge only and back. The first time I did this the app froze.
    screen shot from phone