Windows – Program doesn’t show up in Other Programs in Open With Menu

file associationwindowswindows 7

ever since i upgraded PHPstorm the file association to it has been lost so when i go to the Open With setting to change which program a .php or .xml file opens with, when i go to browse and select C:\Program Files (x86)\JetBrains\PhpStorm 6.0\bin\PhpStorm.exe and hit open it doesn't appear in Other Programs or Recommended Programs and when i hit OK it just associates the original program it was associated with (which happens to be the selected)

this problem isn't just PHPStorm, it happens with Notepad++ since as an alternative i can associate a .php file with notepad++ but it does the exact same thing

i am wondering what's going on and if there is an alternative way to associate files with programs

NOTE: this only happens on my workplace PC, it has never happened on C.C (Home/Gaming/Personal Work PC)

Best Answer

  • Since you tagged the question with Windows 7, I'm guessing you have Windows 7. If you want to continue using the "Open With" context menu, then create a shortcut of the program you use a lot, and place it here:

    C:\Users\<your username>\AppData\Roaming\Microsoft\Windows\SendTo

    Just replace your username with the foldername that corresponds to your Windows logon username.

    Edit: If you want to create a special context menu option which will be static and outside of the "Send To" submenu section, you can add the below code to your Registry. Open Notepad and paste this below in, then save it as OpenWithPHPstorm.reg. I use this code for a Static notepad.exe context menu

    Windows Registry Editor Version 5.00
    [HKEY_CLASSES_ROOT\*\shell\Open with PHPstorm]
    [HKEY_CLASSES_ROOT\*\shell\Open with PHPstorm\command]
    @="c:\path\to\phpstorm.exe %1"

    Edit 2: You could also try right clicking on a phpstorm file, Selecting Properties, and then selecting Change... next to "Opens With", then find and select PHPstorm. This is another way to try and force the association.