Windows – Program in startup folder doesn’t run on startup

bootwindowswindows 7

I used Autohotkey to compile an Autohotkey script and placed the compiled program in the Windows startup folder. When I start Windows, however, the program no longer runs (it used to). I also tried placing the program somewhere else and putting a shortcut to it in the startup folder.

How can I figure out what's happening and fix it?

Best Answer

You Must be aware that some program needs Administrative privilege to start. Keeping program simply in startup folder doesn't provide the program permission to execute it.

  1. You either need to remove the Option to run program as administrator.

    • To do this, right click and go to property of the program and in Advance button of shortcut, uncheck the Run As Administrator.
    • But this may leads to app not work properly for the task it need administrator privilege.
  2. Another option is to create a scheduled task.

    • Open scheduled task and select the program in new task and execute it on every startup.
    • Since Configuring Scheduled task needs admin privilege already, so your program will be already granted admin permission.

So it will work!