Windows – Remove read-only attribute from folder after Windows reinstall

read-onlywindows

I reinstalled a fresh copy of Windows 8.1 on my laptop after formatting drive C. Then I tried to access my Photos folder on drive D and got the error

Access is denied

It turned my folder into a Read Only folder. All other folders on the drive work normally.

I tried using Command Prompt to remove the Read Only attribute but the error message still appears. I tried doing it the simple way (right-click and so on) but the option to change the folder properties from read-only doesn't even appear.

How do I access the folder on my D drive?

Best Answer

The problem isn't that the folder is Read Only. Rather, because your folder was created on a different installation of Windows you no longer have NTFS security permissions to access (read) the folder.

Correct this by following these steps to take ownership and then grant yourself full access to the folder.

  1. Right-click the folder > Properties
  2. Security tab > Advanced
  3. Click Change to the right of Owner
  4. Enter Users into box and click OK
  5. Enable the checkbox Replace owner on subcontainers and objects then click Apply
  6. If prompted that You do not have permissions to read... click Yes
  7. Completely close out of the Advanced Security Settings dialog
  8. Right-click the folder > Properties
  9. Security tab > Edit...
  10. Add...
  11. Enter Users into box and click OK
  12. Enable the Full Control checkbox then click OK