Windows – “Safely Remove Hardware” icon in Windows 8

iconsnotification-areasafely-remove-hardwarewindows 8

In Windows 8 the "Safely Remove Hardware" icon sits permanently in the System Tray even though no external drive is plugged into the computer. If you click on that icon the only clickable option is "Open Devices and Printers." Hiding this (or any other) icon causes the "Show Hidden Icons" icon to display in the System Tray. Can the "Safely Remove Hardware" icon be removed from the System Tray without hiding it? Thanks.

Best Answer

I had a similar problem with Windows 8. When I clicked on the icon in the system tray, it displayed "Open Devices and Printers" along with three dots, like "..." underneath. All of my USB cables and devices were disconnected from my computer except the USB mouse and USB keyboard. I selected "Open Devices and Printers" and removed a device called "USB 2.0 Reader". The icon immediately disappeared.

When I restarted my computer, the operating system started to automatically re install the "USB 2.0 Reader". The icon reappeared along with the three dots. Keep in mind, there is no USB reader attached to the computer.

Instead of removing the device (Windows would just re install it again), I decided to disable it. I opened the Windows Device Manager and selected the "Disk Drives" and selected "Generic - Multi-Card USB Device". I right clicked it and selected "Disable". The icon immediately disappeared.

I restarted my computer and the icon did not reappear. The device still shows up in the Device Manager, but it is disabled. The keyboard and mouse continue to work and I can connect my Windows phone to my computer.

It isn't clear what the root cause is, but I was able to remove the icon, stop Windows from re installing it, and if there is a problem in the future, I can always enable the device again. Also, this allows other "actual" devices to be connected and display the icon in the system tray (the true intention of the notification icon).

Hope this helps!