Samsung Series 5 BIOS not detecting any bootable devices


so I have a problem with my BIOS, it doesn't detect any bootable devices from the Boot tab.

NOTE: I'm gonna refer to keys and tabs that show in my BIOS settings page for ease of explanation. Please refer to the images below to see such tabs/keys.

So here is what happened:

I have a Windows installation in my HDD. I was trying to install Ubuntu from a USB drive, it showed up when I pressed F10 (key in this computer to select the device to boot from) but it wouldn't boot from the USB just like that, so I entered into the BIOS settings and in the Advanced tab I read on the right that by disabling Fast boot mode legacy USB is supported, so I disabled it, saved and reset. But it wouldn't boot anyway, I played around with some settings but nothing had changed to this point… even though I couldn't boot from USB, my Windows was still booting from my HDD.

But in one of those times I was changing settings, I mispressed F9 (loads optimised defaults) instead of F10 and hit enter, and from here I can't see ANY bootable devices under the Boot tab and now I can't even boot Windows anymore, as well not from my USB either. When I power on my laptop, it just shows the Samsung splash and it enters in the settings page by itself.

Can anyone please help me get my bootable devices found by the BIOS again? Thanks in advance!!

Here is my current BIOS settings:

SysInfo tabAdvanced tabBoot tabno boot devicesno bootable devices on F10

Best Answer

OK I figured it out.

Under the Boot tab I needed to Disable Secure boot, this added an option to choose a boot option which includes CSM, UEFI and CSM and UEFI. Searching over the web I found that, at least the BIOS version in Samsung Series 5 (not sure if all Series X) does not work quite well with UEFI by itself, but it needs compatibility support.

So by using CSM or CSM and UEFI I was able to get my bootable devices listed again (I still wonder why the maker sets UEFI as an "optimised" default if it's not totally supported).

And by disabling Fast boot mode under Advanced tab, bootable USB is now running!

Anyways, thanks for your help!! :)

Related Question