Slow Internet speed when HomePlug combined with router

cable-modeminternetnetworkingpowerline-networkingrouter

I'm using HomePlug AV2 600 devices to connect upstairs with downstairs (router is downstairs). A check with iperf shows bandwidth of ~100Mbps, and data transferred on the local network from downstairs to upstairs is transferred at about that speed. Good times.

But when I try to access the Internet from upstairs, maximum throughput is only 40Mbps. Bad times.

If I try from downstairs, I get the full 80Mbps that my Internet connection allows. This is really puzzling, as I know the HomePlugs are working faster than that for local data.

Here's what my setup looks like (the router is connecting to a fibre modem using PPPoE, everything has gigabit ports, and all testing was using wired connections):

                         +----+                           
                         | PC |                           
                         +-+--+                           
                           |                              
                           |                              
                       +---+----+         +----------+    
                       | Switch +---------+ HomePlug |    
                       +--------+         +-----+----+    
                                                |         
    Upstairs                                    |         
+-------------------------------------------------------+
    Downstairs                                  |         
                                                |         
  +-------+ PPPoE +-----------------+     +-----+----+    
  | Modem +-------+ Wireless Router +-----+ HomePlug |    
  +-------+       +-----------------+     +----------+    

If I connect to the router downstairs (wired), then it works great:

                       +--------+         +----------+    
                       | Switch +---------+ HomePlug |    
                       +--------+         +-----+----+    
                                                |         
    Upstairs                                    |         
+-------------------------------------------------------+
    Downstairs                                  |         
                                                |         
  +-------+ PPPoE +-----------------+     +-----+----+    
  | Modem +-------+ Wireless Router +-----+ HomePlug |    
  +-------+       +-----------------+     +----------+    
                           |                              
                           |                              
                        +--+-+                            
                        | PC |                            
                        +----+                            

If I wire the downstairs HomePlug straight to the modem, and setup a PPPoE connection from the Windows 7 machine upstairs, it also works as expected:

                         +----+                           
                         | PC |                           
                         +-+--+                           
                           |                              
                           |                              
                       +---+----+         +----------+    
                       | Switch +---------+ HomePlug |    
                       +--------+         +-----+----+    
                                                |         
    Upstairs                                    |         
+-------------------------------------------------------+
    Downstairs                                  |         
                                                |         
  +-------+            PPPoE              +-----+----+    
  | Modem +-------------------------------+ HomePlug |    
  +-------+                               +----------+    

I've also tried plugging the HomePlugs in right next to each other on the same floor, and get the same poor results:

    Downstairs                                          

  +-------+ PPPoE +-----------------+     +----------+    
  | Modem +-------+ Wireless Router +-----+ HomePlug |    
  +-------+       +-----------------+     +-----+----+    
                                                |
                                                |
                               +----+     +-----+----+    
                               | PC +-----+ HomePlug |    
                               +----+     +-----+----+  

So the issue is only there when connecting to the Internet through both HomePlugs and the router, and only affects WAN traffic. I've tried replacing the router with a newer model, but get the same result. I also tried replacing the HomePlugs with a different brand (first tried Solwise, now Devolo).

I've also tried creating a PPTP VPN tunnel between my upstairs computer and the downstairs router – and this does inexplicably gives me the full bandwidth I would expect. But this relies on using DD-WRT on my router – and it's very flakey.

I'm at a loss, so any help would be much appreciated!

Best Answer

  • What happens if you plug both powerline devices into the same plug strip AND turn off every circuit breaker in the house except the one powering this circuit? (i.e. Eliminate all possible sources of powerline noise.) If you find this resolves your speed issue then turn breakers back on one at a time until you find which has the noise source (and it may not just be one, but you get the idea). The difference between protocols I expect is exactly that... other protocols have better error correction than TCP.