Windows – Stop Windows Media Player showing synchronization dialogue when USB device plugged

syncusbwindowswindows media player

Every time I plug a USB stick into my PC, I get this synchronization dialogue in WMP. It's really annoying, and it also stops my Play/Pause shortcut keys working.

This is really starting to annoy me.

I've found one link which mentions this problem and possible solutions, including a registry hack, but without giving details.

Is anyone else bothered by this, and has anyone found a solution?

EDIT OK, after reading here and here, I fiddled round a bit, ended up synchronising just one file, and then when I next inserted the USB stick, no more popup… Not great, but better.

Best Answer

  • Disable and stop service WPDBusEnum aka Portable Device Enumerator Service

  • Related Question