Sublime Text automatically removes the indent

sublime-text-3

I recently updated my copy of Sublime Text to 3. Everything is awesome, except one thing that is driving me crazy. Whenever I indent my line with the tab key, it automatically undoes it. I then have to hit tab a second time for it to 'stick'.

Example

<html>
    <body>
    </body>
</html>

This is how I want my HTML to be presented, however, when I open the bracket of the 'body' tag, sublime automatically adjusts my line to

<html>
< -- I don't want to type here, Sublime!
</html>

I then have to delete my '<' and hit tab a second time. At this point it will allow me to type with the indent.

I expect this is some kind of preference that has been enabled, but I have no idea what to look for.

Anyone know how I can change this?

Thanks

Best Answer

Add "trim_automatic_white_space": false to your user settings. When set to true, auto indent tabs will be automatically removed when the cursor is moved off of the line.