Windows – UAC keeps resetting on Windows10

group-policyuacwindows 10windows-registry

I have a Windows10 Enterprise machine on which I want to disable UAC completely in order to execute all applications as Administrator per default.

However, my UAC settings keep resetting every time after a reboot.

I tried the following solutions:

  • Setting the following values in the registry hive HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System:
    • EnableLUA to 0
    • ConsentPromptBehaviorAdmin to 0
  • I even made myself the effective owner of the registry hive above and denied every other user (incl. SYSTEM) to modify it.
  • Setting the following group policies:
    • Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Behavior of the elevation prompt for adminsitrators in Admin Approval Mode to Elevate without promting
    • Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Run all administrators in Admin Approval Mode to Disabled
    • There is an other setting somewhere around Computer Configuration\Administrative Templates\System\ ??? which disables the automatic overriding of Group Policy Settings.
  • Reinstalling a fresh copy of Windows10
  • Writing a script in C# executed on every boot which sets all these settings for me – it did not work as not even Admin Privileges apparently are high enough to change these settings…

None of the above solutions –including the Windows re-installation– helped resolving the problem.

I am aware that Windows10 has trouble running the WindowsStore and MSEdge etc. when one has UAC completely disabled – but I do not care as I do not use any of these "features".

Does anyone have a solution which I have maybe not yet tried?


As a developer, this drives me completely nuts.


Edit:

Completely disable UAC in Windows 10 is not a duplicate of my question, as I have tested all the proposed solutions in the linked question and they did not work for me (as specified above).

Best Answer

  • Open gpedit.msc and navigate to Computer configuration -> Windows settings -> Security settings -> Local policies -> Security options. Under that, disable User Account Control:Run all administrators in Admin Approval Mode.

    Here's what the documentation for Admin approval mode says:

    If a computer is upgraded from a previous version of the Windows operating system, and the administrator account is the only account on the computer, the built-in administrator account remains enabled, and this setting is also enabled.

    This is indeed the case for me - I have upgraded from Windows 7 Ultimate -> 8.1 -> 10, and mine is the sole administrator account. If that's the case for you too, well - seems this can't be fixed without a fresh install of Windows with a separate administrator account.

  • Related Question