Ubuntu – TightVNC and ubuntu desktop not working properly

tightvncubuntu 16.04

For the last days i have been experimenting a lot with remote desktops. For our company we want to install ubuntu 16.04 desktop on a headless server. I succeeded in installing tightvnc server which gives me unique desktops for each employee, along with graphical ubuntu desktops. But things are not working as it should. And a lot of things seem not be working correctly.

  1. I can't change the account type of a user, even tough i have added a user to sudo group. If in the gnome user manager i try to change the account type, or when i click advanced options. It does nothing. I used commandline stuff etc, but still the account that i use stays a custom account which i can't click/change/edit.

  2. Start menu does not show all menu's of software that is installed, even tough they are checked and visible in alacarte.

  3. System settings menu is incomplete and not all menus or options are showed.

  4. User menu does not show up.

It all seems rather incomplete to me, and it has probably somethings to do with my xstarup file. I tried many examples from the internet for xstartup files. This is the closest as i could get for a proper working ubuntu desktop. If only i could get the menus working like it should, i would be really happy. So if anyone has any idea's of what could be wrong? Do i have missing packages? Are it just bugs? Any tip or hint is very much welcome.

My xstartup file looks at the moment like this:

#!/bin/sh
export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &

Am i missing anything? Or is the XFCE desktop, the only one that works properly? I have googled plenty of vnc tutorials/forums etc, and i read lots of problems and weird issue's regarding a proper functioning gnome or ubuntu desktop.

Best Answer

You need to add two exports for XDG_CURRENT_DESKTOP and XDG_MENU_PREFIX:

export XDG_CURRENT_DESKTOP="GNOME-Flashback:Unity"
export XDG_MENU_PREFIX="gnome-flashback-"

Then you probably want / need to replace gnome-settings-daemon with unity-settings-daemon and add also gnome-flashback.

You can try to use gnome-settings-daemon, but then XDG_CURRENT_DESKTOP should be GNOME-Flashback:GNOME, you still need gnome-flashback.