Ubuntu – Update to nvidia-drivers on Ubuntu 18.04 makes the laptop display not accessible but external display is working

multiple-monitorsUbuntuxorg

Update to nvidia-drivers on Ubuntu 18.04 makes my laptop display not accessible but external display is working. My current display driver is nvidia-410 for GTX 1070, it's the recommended option.

Weird stuff is external 4K monitor is working perfectly but laptop screen is not working. Laptop screen just open at start then after logging it stops and only external display works. If external display is not connected than after login screen laptop screen shuts/freezes.

I can confirm that xorg.conf doesn't have an entry for lvds and even output of xrandr -q doesn't show lvds display.Please help. For reference my xorg.conf is

Section  "ServerLayout"

    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"

    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Output for xrandr -q says:-

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 621mm x 341mm  
   3840x2160     60.00*+  59.94    50.00    30.00    29.97    23.98  
   1920x1080     60.00    59.94    50.00    29.97    23.98    60.00    50.04  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x768      59.87  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)  
DP-1 disconnected (normal left inverted right x axis y axis)

whereas xrandr --listdisplays is :-

Monitors: 1  0: +*HDMI-0 3840/621x2160/341+0+0  HDMI-0

As you can see LVDS is absent from everywhere.

To show nvidia driver is working properly on external monitor the output of nvidia-smi is able to run and give correct information about external display.

Best Answer

  • Delete /etc/X11/xorg.conf

    Spent hours trying to fix this and this was what did it.