Windows – Unable to access smb share on external USB on ubuntu 19.10 from windows 10

sambaUbuntuwindows 10

I've tested this on both EXT3 and NTFS USB drives (the same one, reformatted) – when I share a directory on an external USB drive as a smb share on a ubuntu 19.10 PC, I cannot access it using a PC running windows 10. I've tried setting a share from my home directory, and the windows 10 PC is able to access it.

Its mounted on /media/geek/1 TB and there's a few things using it. I'd like to have a directory inside it, lets call it "stuff" shared.

I've tried both mounting the drive itself through nautilus and fstab.

I'd like a simple, passwordless guest share

The fstab line was #UUID=25454a67-7700-4e4f-a3af-538719d73ce5 /media/geek/1%40TB ext4 rw It works locally with no issue.

When I share the folder either through nautilus' local file share option or by samba – and I'm trying with this very basic config file

[Stuff]
        comment = Torrent_Share
        path = "/media/geek/1 TB/Samba"
        browseable = yes
        read only = no
        guest ok = yes

I've also tried renaming the mountpoint without a space.

On the windows end, the error I get is

enter image description here

On the Ubuntu side – looking at the log file for the windows client /var/log/samba/log.aurora shoes a rather cryptic error

geek@torrent-box:/media/geek$ tail /var/log/samba/log.aurora
[2019/12/14 18:00:50.380192,  0] ../../source3/smbd/uid.c:448(change_to_user_internal)
  change_to_user_internal: chdir_current_service() failed!
[2019/12/14 18:00:50.380727,  0] ../../source3/smbd/uid.c:448(change_to_user_internal)
  change_to_user_internal: chdir_current_service() failed!
[2019/12/14 18:00:50.382387,  0] ../../source3/smbd/uid.c:448(change_to_user_internal)
  change_to_user_internal: chdir_current_service() failed!
[2019/12/14 18:00:50.383049,  0] ../../source3/smbd/uid.c:448(change_to_user_internal)

We can rule out permissions

geek@Stuff-box:~/Desktop$ stat share
  File: share
  Size: 4               Blocks: 2          IO Block: 512    directory
Device: 34h/52d Inode: 40498       Links: 2
Access: (0777/drwxrwxrwx)  Uid: ( 1000/    geek)   Gid: ( 1000/    geek)
Access: 2019-12-14 18:00:46.352195708 +0800
Modify: 2019-12-14 18:00:46.324194693 +0800
Change: 2019-12-14 18:00:46.324194693 +0800
 Birth: -

This works

geek@Stuff-box:/media/geek/1 TB$ stat Stuff/
  File: Stuff/
  Size: 4096            Blocks: 8          IO Block: 4096   directory
Device: 811h/2065d      Inode: 52166657    Links: 6
Access: (0777/drwxrwxrwx)  Uid: ( 1000/    geek)   Gid: ( 1000/    geek)
Access: 2019-12-14 20:51:42.364000000 +0800
Modify: 2019-12-14 18:26:37.434393399 +0800
Change: 2019-12-14 18:26:37.434393399 +0800
 Birth: -

This does not.

I've tested the local file share/gui route on a directory on my home directory and it works fine. How do I actually get that folder sharable through some means?

Best Answer

  • After a little interactive debugging on chat - apparently this might be an issue with the gnome file sharing system (which oddly isn't actually using samba).

    using this manual samba config for the share worked

    [Stuff]
    comment = Stuff_Share
    path = "/media/geek/1 TB/Stuff"
    browseable = yes
    read only = no
    guest ok = yes
    public = yes
    force user = geek
    

    Added it to the end of smb.conf and restarted samba and it worked.

    I also had to start the samba service and enable it.

  • Related Question