Very slow Wi-Fi download speeds using a TP-LINK WR841N (1/10th of full Ethernet speed)

ethernetrouterwireless-networking

I have 105/10 internet through Comcast and I have a TP-LINK WR841N router. I use Ethernet and Wi-Fi. I get ~100Mbps through Ethernet, and only around 10 Mbps through Wi-Fi. Yesterday I had ~50Mbps on Wi-Fi but even that is half of of the original speed. Any suggestions? This really sucks as this router was rated really high by a lot of users.

Here are some details:

Hardware Version:

  • WR841N v9 00000000

Firmware Version:

  • W3.16.9 Build 141013 Rel.61626n

Wireless:

  • Wireless Radio: Enable
  • Name (SSID): Motorola
  • Mode: 11bgn mixed
  • Channel Width: 20MHz
  • Channel: 11
  • WDS Status: Disable

Best Answer

  • In ideal conditions, such as a perfectly interference-free channel and a good client just 2-3 meters away, you should be able to get over 200Mbps of TCP/IP throughput out of an AP that does the 300Mbps flavor of 802.11n.

    From the information you've given, one obvious thing to try is to set the channel width to 20/40MHz instead of 20-only. Your AP can only do 144.4 Mbps signaling when limited to traditional 20MHz-wide channels. To get its 300Mbps max rate, it has to use 40MHz-wide channels.

    However, you should beware that the 2.4GHz band is often congested (other Wi-Fi users, Bluetooth, cordless phones, microwave ovens, wireless security cams/webcams, baby monitors, non-Bluetooth wireless mice and keyboards, wireless speakers and subwoofers, Nintendo Wii remotes, etc.), and trying to find a clean contiguous 40MHz-wide swath of that band is more than twice as hard as finding a clean 20MHz-wide swath.

    Side note: Because Apple likes to leave some room for Bluetooth devices to have a fighting chance of working well, Apple has traditionally limited all of their 802.11n and 802.11ac-capable devices to using only 20MHz-wide channels when operating in the 2.4GHz band. They still use 40MHz or 80MHz wide channels in the 5GHz band. So if your client device in question, is, say, a MacBook, then setting your WR841N to 20/40MHz mode won't help, because your WR841N only supports the 2.4GHz band. You'd want to replace it with a simultaneous dual-band (a.k.a. dual-band concurrent) AP.

    If enabling 20/40MHz mode doesn't solve the problem, here are some other things to try:

    • Make sure your client is capable of the 300Mbps flavor of 802.11n in the 2.4GHz band (2 spatial streams, short guard intervals, 40MHz-wide channels).
    • Make sure your AP is set to use the cleanest possible 40MHz swath of the 2.4GHz band. Try other channels; try turning off other things that could be generating 2.4GHz RF noise; use a tool like inSSIDer to see how neighboring Wi-Fi networks might be interfering with you; etc. If you bought a $20 AP, I'm not going to tell you to spend many times that buying a Wi-Spy or other 2.4GHz spectrum analyzer, but I love my Wi-Spy dBx.
    • Try turning off other things that may be making traffic on your home network, especially if they're older 802.11g or especially 802.11b gear. It's a myth that the presence of those things will drop the whole network down to the old low speeds, but those old devices can consume a lot more wireless airtime for the same amount of traffic, and the modern devices take a performance penalty by having to use various protection mechanisms to keep the older gear from stepping on modern transmissions they can't detect.
    • Make sure your client is 2-3 meters from the AP (too close can overload the radio and cause distortion; too far and you signal strength might no be enough to sustain the top data rates).
    • If you have wireless security enabled, make sure it's WPA2. 802.11n requires WPA2 if you're going to use security. The original WPA, and WEP before that, used hardware RC4 cipher engines that couldn't keep up with 802.11n-era data rates.
    • Make sure you have WMM (a kind of wireless QoS) enabled on both your AP and client, if they give you the option. 802.11n requires WMM. If you disable WMM, you're effectively disabling 802.11n. Some APs and clients aren't smart enough to warn you about that. If they don't give you an option to enable/disable WMM, they must have it on by default which is great.
  • Related Question