Windows – VirtualBox Windows 7 Host, XP Guest cannot play audio

audiovirtualboxwindows 7

As the subject says, I cannot get an XP guest to produce sound on my Windows 7 Ultimate 32bit host. Sound works fine in the host OS.

If I set the host audio driver to "Null Audio Driver" and the audio controller to ICH AC97, all appears to work, except no sound comes out the speakers. The Intel AC'97 Audio Controller shows up in my list of devices. As I understand it, that's what happens with Null Audio Driver. If you want sound, you need to select the Windows DirectSound for the host audio driver. If I do this, though, then when I start up the XP guest, it hangs with a dialog box titled "XPPro: Starting virtual machine" and the message "Starting virtual machine…" with a progress bar stuck at 0%. Here are the last few lines of my log file:

00:00:00.840 NAT: adding 24.116.2.50 to DNS server list
00:00:00.840 NAT: adding 24.116.2.34 to DNS server list
00:00:00.840 NAT: value of BindIP has been ignored
00:00:00.841 Audio: Trying driver 'dsound'.
00:00:00.936 Audio: set_record_source ars=0 als=0 (not implemented)

At that point the only thing I can do is kill the startup window. Setting the controller to soundblaster 16 lets the guest come up, but no audio device shows up in device manager or in the control panel app.

Any ideas how I can get sounds out of my guest OS?

UPDATE

I just finished installing VMware 3.0 and loading XP Pro there. Works like a charm. On the VBox forums, I was asked to submit a bug report, I guess there is an issue there.

Best Answer

  • I am running VirtualBox (3.1.2 when posted) on a Windows 7 Host, and my Windows XP Guest plays audio just fine. Here are my settings, I hope they help you:

    Audio

    • Enable Audio: checked
    • Host Audio Driver: Windows DirectSound
    • Audio Controller: ICH AC97

    To me it sounds like there is some sort of conflict with your host audio driver. Does this happen if you install a fresh new clean copy of Windows XP as a guest?

    Any chance your could try to either upgrade your existing driver, or completely uninstall your audio device and reinstall it again?

    One last thought, on the host, can you try changing the default audio device (Start -> Control Panel -> Sound) and try setting one of the other devices as the default? You may also want to go into the advanced settings for the device and reset the settings back to their defaults (most tabs have a button for that). Last, on the Advanced tab, there are some options for Exclusive mode. Ideally both should be checked, but try disabling them and see what happens.

  • Related Question