Chrome – WebMatrix/IIS Express only works with Opera!

firefoxgoogle-chromeiisinternet explorersafari

When I try to test (or "Run"…) my WebMatrix website (PHP) (IIS Express), only Opera works.
All other browsers refuse to connect to the server ("http://localhost:55555/", for example).

Internet Explorer 9 says

This problem can be caused by a variety of issues, including:
•Internet connectivity has been lost.
•The website is temporarily unavailable.
•The Domain Name Server (DNS) is not reachable.
•The Domain Name Server (DNS) does not have a listing for the website's domain.
•There might be a typing error in the address.
•If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

So, basically, it just doesn't work.

Firefox, on the other hand, is a little more dumb:

The connection has timed out

          The server at is taking too long to respond.

  The site could be temporarily unavailable or too busy. Try again in a few
  If you are unable to load any pages, check your computer's network
  If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

First of all, it tries to change my "localhost" no matter what…

Google Chrome is too shy to explain me the problem:

Oops! Google Chrome could not find localhost:55555

I couldn't expect more…

Safari, on the other hand, did better than I ever expected.

Safari can’t open the page “http://localhost:55555/” because Safari can’t find the server “localhost”.  

So, what can I do about this?
How can I test my WebMatrix website with other browsers?

Edit: Apparently, bumping… What is there not to understand? Please ask for more info if you need and I will give.

Edit2: This THING happens on my brother's laptop (which I use most of the time) and my desktop.
It does not happen on my netbook.
On my desktop and my bro's laptop, we have Opera as our default browser and IE9.
On the netbook, I have Chrome because it starts faster and IE8.

Can the update to Internet Explorer 9 cause this?

One more thing I noticed when opened in IE8 is the Intranet Settings option, which I cannot find in IE9.

Best Answer

First let's see if it is actually running off port 55555. Try:

netstat -a | find "LISTENING"

You should see an entry on port 55555. If it is in fact running your service. In any other case, open a browser and try instead of using localhost. Most of the time this isn't an issue, but it's best to cover our bases.

If that still doesn't work, my suspicion is a misconfiguration of the service itself. Another option, if you can't get this to work is to set up an Apache web server instead of using IIS.