Windows – What do I have to index in order to search the Windows Control Panel (in Win10)

windows 10windows-desktop-search

In Windows 7 and 8, if I click the Start menu then start typing, the search results I see include Control Panels — I could type "Mouse" or "Network" and see icons for the relevant control panels. In Windows 10, this isn't working. I've gone into Indexing Options and looked all around, but can't find anything to index that would make these show up. Do I have to figure out where the relevant .msc launchers reside?

Best Answer

  • A lot of people are reporting this issue in various forms.

    In most cases it involves multi-lingual installations, but not necessarily. Even in mono-lingual installations this can happen, but the cause stills seems to be related to the multi-inequality feature.

    The best analysis of the problem has been reported here, by DavidCRobinson. Below I have edited his solution to the essence:

    The Issue
    Windows saves the entries of the Control pannel settings in the user profile - the location is:

    %LOCALAPPDATA%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\Indexed\Settings

    Under the above should be your default language directory (e.g "en-GB" or "en-US") and within this a list of ALL the available 'Settings' to be searched.

    Problem 1
    For some users this language pack and list of settings is NOT getting created for new users, ONLY the very first user profile created in Windows 10. The result is that you've got no settings indexed to even search for.

    Problem 2
    For some users, the folder exists, but there is something wrong with the Indexing properties of the directory. (skip to Solution Part 2)

    Problem 3
    For some other users, this folder exists, and the Indexing properties work, but the folder is not being indexed. (skip to Solution Part 3)

    Problem 4
    You have done all of the above, but the Index needs to be rebuilt. (skip to Solution Part 4)

    Solution - Part 1

    • Find a computer or user on your own computer where the search function can find Control Panel items.
    • On this system go to C:\Users\workinguserprofilename\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\
      and copy the Indexed folder.
    • Copy this folder to your own LocalState folder

    Solution - Part 2

    • Go to %LOCALAPPDATA%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState
    • Right click on the Indexed folder -> Properties ->Advanced
    • Deselect Allow files in the folder to have contents indexed...
    • Click ok and select apply to subfolders and files
    • Right click on the Indexed folder -> Properties ->Advanced
    • Select Allow files in the folder to have contents indexed...
    • Click ok and select apply to subfolders and files

    Solution - Part 3

    • Go to Control Panel -> Indexing Options (obviously not through search ;) )
    • Click Modify -> Show all locations
    • Make sure your username is listed in the Summary of selected locations, and the AppData folder is not mentioned in the Exclude list.
    • If The AppData folder is excluded, or your user is not listed, first change your File explorer setting to show hidden folders.
    • re-open the Indexed Locations menu
    • Navigate to your user folder and select it, making sure the AppData folder is also selected.

    Solution - Part 4

    • Go to Control Panel -> Indexing Options -> Advanced
    • Click Rebuild and wait until the Indexing Options menu sais Indexing complete (this can take a while).

    Sidenote People experiencing this issue also report that when searching the message These results may be incomplete is constantly being shown. After applying these fixes, this issue should also be gone.