Why there are ‘~(tilde)’ in every file’s extention when I edited with gVIM

gvimvim

I'm using gVIM on Windows.

Everytime I edit text file and save it, VIM makes a file with '~(tilde)' in extention
– like this : 'crappycode.txt~'

It's so annoying that I have to delete it manually.

Is there any option that stops gVIM to make such file?

p.s. sorry for bad english.

Best Answer

This sounds like a temporary file being created by vim. Just add the following to your .vimrc

set nobackup