Windows – Wifi network undetectable on a Lenovo G470

connectionlenovo-laptoptroubleshootingwindowswireless-networking

I have a WPA2 secured network with a visible SSID at home that works perfectly fine with a Dell laptop,a HP netbook and sundry mobile phones. When I try connecting my sister's Lenovo G470, it refuses to detect the wifi network no matter what, but shows up the neighbors' networks. The Lenovo also works correctly at her office. Both laptops run Windows 7.
Already tried/checked the following:

  • Manually configure wifi network settings (copied over from the Dell)
  • Ensure there is no MAC address filtering on the router.
  • Ensure router DHCP server is not running out of addresses to assign (I have set it to allocate upto 10).
  • Reboot laptop, router etc.

Is this a known problem, and is there anything else one could try?

Update – The problematic Lenovo uses Windows 7 Home Basic while the Dell that works uses Home Premium and the HP netbook uses Starter edition – if that makes any difference.

Further update – It is able to connect if I reboot into safe mode with networking. However in 'normal' mode it shows up the network sporadically, and then says there was an error connecting to it.
All the network parameters, password, encryption, etc etc are EXACTLY the same as they are on the Dell.

Best Answer

  • Check your router's settings for the encryption method used for the WPA2 protocol.

    My router supports both WPA & WPA2, using both TKIP & AES encryption. But TKIP is the lesser of the encryptions, it came out with WPA, and is usually 'linked' to being used with WPA.

    AES is 'linked' to WPA2. Apologies, hard to explain the relationships, AES goes with WPA2, TKIP with WPA... something like that.

    I had issues in the past because I wasn't aware of the 'linking' and had WPA2 with TKIP, and I suppose some of my devices didn't like the combination. Choosing AES with WPA2 resolved most of the issues, but I also found some of my older devices didn't like WPA2 (sigh). So today my router does 'WPA/WPA2' with 'TKIP/AES'. Not my favorite configuration, but it's got everything working finally.

  • Related Question