Windows 10 black screen after local login and previous remote desktop session

remote desktopwindows 10

On occasion when I am not physically at home, I will login remotely to my computer using Remote Desktop. When I return home I then have to login locally; however, immediately after login I am presented with a black screen. Has anyone else encountered this issue and know of a solution?

Additional Information

As far as I can tell the system appears to switch over to virtual devices for the remote desktop session, but when I then login locally it doesn't switch back to the physical devices.

I don't have any trouble with local logins normally. And I can login remotely repeatedly without issue. It's only when I attempt to login locally after I have been logged in remotely that the issue occurs.

While viewing the black screen, Ctrl-Alt-Del does not appear to do anything. There is a mouse cursor visible that I can move around for a short time (5-10 seconds) before it freezes. Once it reaches this point, the only remedy I have found is to hard restart my computer physically using the power button.

The computer was upgraded from Windows 7 where I used to do the exact same thing and had no trouble at all. I could remote desktop into my computer assuming the existing session, then login locally and assume the same session, and repeat as I wished.

I have uninstalled and reinstalled drivers for my monitor (Samsung SyncMaster T240HD) and display adapter (EVGA NVIDIA GeForce GTX 670). I have logged into safe mode, enabled display all hidden devices, and uninstalled all other monitor or display adapter devices that I could find, which was only a single hidden monitor device for an old monitor I had.

I have checked the system, application, and security logs and found no warnings or errors either during the remote login or the subsequent local login.

Best Answer

Issue is related to the nVidia GeForce Experience ShadowPlay feature. When ShadowPlay is turned on (not recording just enabled), then the issue occurs. When ShadowPlay is turned off, then no issue. Whether the issue is ShadowPlay or Remote Desktop I can't say, but the two of them interacting together on Windows 10 caused the black screen of death.

I'm not the only one to notice this problem. The only reason I even played with the setting was because someone else had a similar issue with a different version of the software: https://serverfault.com/questions/724459/black-screen-after-rdp-session