Windows 10 keeps waking from sleep

sleepwake-upwindows 10

My computer has been waking out of sleep since I've upgraded to windows 10. It usually sleeps for many hours before waking. This is a desktop PC.

C:\WINDOWS\system32>powercfg lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\WINDOWS\system32>powercfg -devicequery wake_armed

I have "Allow sleep timers" disabled under the advanced power settings.

Automatic maintenance "Allow scheduled maintenance to wake my computer at the scheduled time" is unchecked.

"Wake the computer to run this task" under "Task Scheduler" is unchecked for all tasks.

I do not have TeamViewer installed which was this guy's problem

Does anyone have any idea what could be waking my PC up or what I could do to identify it? Or if there is any way to force the PC to sleep no matter what until I hit the power button?

Best Answer

The "Wake on Magic Packet" option may turn the computer on (if someone/something is pinging the computer). Go through Device Manager to resolve this and not the Network and Sharing Center (see EXPLANATION below).


  1. Open the "Device Manager"
  2. Open the "Network adapters" tree
  3. Select your adapter (you may have two if you have both wireless and Ethernet capabilities)
  4. Right-click on the adapter
  5. Select "Properties"
  6. Select the "Advanced" tab
  7. Under the "Property" box, scroll down and select "Wake on Magic Packet"
  8. Change the "Value" drop-down box to "Disabled"

EXPLANATION: You can go through the "Network and Sharing Center" by selecting "Change adapter settings" on the left side of the screen; selecting your adapter's "Properties"; selecting "Configure"; and then going to the "Power Management" tab. However, I've noticed on some of my computers (including Windows 7), that the magic packet option will be grayed out or unchecked in the "Power Management" tab but be "Enabled" in the "Advanced" tab.

Using the Device Manager route solved my issue with unwanted waking from sleep on my laptop. Good luck.