Windows 10 Pro anniversary update forces automatic reboot on new updates

rebootwindows 10windows updatewindows-10-v1607

Is there any way to stop Windows 10 Pro from rebooting after installing updates? After the anniversary update, it seems I no longer have the ability to control this.

There is a group policy I have set, but my understanding is that this is now ignored.

I have processes that I run overnight, and I simply cannot have Microsoft dictate when to turn off my computer. There must be a way to stop the reboot.

Best Answer

  • You have few options you can do, you can either do as @cybernard said in his comment

    You can set active hours for the reboot between 2 ranges,under settings, updates,update status, active hours. You can set it so microsoft can reboot only during 1 particular hour if you want to. Additional updates are only released 2nd tuesday of the month, unless its an emergency.

    or you can defer upgrades in the advance options since you have the pro version of windows 10.

    There is few other options that I have learned because you have Pro, as well as I do myself.

    Right click your start button and select run and type

    gpedit.msc
    

    Navigate to Computer Configuration\Administrative Templates\Windows Components\Windows Update.

    on the right hand side double click Configure automatic updates and set it to enabled. Then you can tell it what you want it to do. You can even edit the registry as well but I am not sure where nor do I recommend messing with the registry.

    The other thing you can do, is set your connection as metered. If you tell windows your wifi or ethernet connection is metered, it won't download updates automatically.

  • Related Question