Windows 10 Remote Desktop Connects with Black Screen then Disconnects

black-screen-of-deathconnectionremote desktopwindows 10

I've been having this issue since I updated (fresh install) to Windows 10 Professional. I used to connect to my computer via RDP through WAN and LAN with no issues.

After installing W10 and setting up everything correctly (ports, static IP etc) I still can connect, but during the day it randomly kicks me out and I can't successfully log in afterwards. It makes a secure connection and connects, but I get a black screen without a cursor and disconnects a few seconds after that without any errors.

It's an Intel i7 desktop with nVidia GPU with the latest drivers.

Things that I know/tried:

  1. When issue occurs, I can replicate it on Windows, Mac, or iPads/iPhones over LAN or WAN.

  2. Rebooting temporarily fixes the problem, until it starts happening again.

  3. Disabling bitmap caching or changing resolution on RDP client doesn't fix it.

  4. Pressing CTRL + ALT + END doesn't do anything.

  5. Created a new account and tried logging on to that to test if it is account related, still didn't log in.

  6. Did a sfc /scannow to do a system scan and fix corrupt files, it came out with no errors.

  7. I checked the event log and apparently WINLOGON keeps crashing. It only says "the windows logon process has unexpectedly terminated"

I ran out of options to fix this, any help will be appreciated.

Best Answer

Remote Desktop – Black Screen Of Death

The Issue

Using Remote Desktop the remote screen turns black right after login and you have no control. The issue appears to be caused by Screen Caching and accessing a system with different display resolution or RDP window sizes.

The Solution(s)

  • While logged in and stuck on the black screen of death
    1. Press CTRL+ALT+END, or CTRL+ALT+FN+END on laptops. This calls Task Manager and in most cases you’ll immediately see the Desktop.
    2. If only Task Manager but no Desktop appears try running Explorer from Task Manager: File > New Task > Explorer.exe
  • Try connecting at a different resolution.
  • Access the remote computers Computer Management or Services MMC and cycle the Remote Desktop Services service.
  • Update display drivers, both on the connecting machine and on the machine you are connecting too.
    1. Some users are experiencing this with Nvidia GPUs. The Geforce Experience program has a "Share" feature aka "shadow play"; when enabled some people experience the problem. Try to disable it, restart and see if it helps.
    2. Check the display settings at the remote host and see if there is a phantom monitor present. Might need to change which monitor is the primary one
  • Start a new RDP client on your desktop but BEFORE you click CONNECT, click the SHOW OPTIONS link, click the DISPLAY tab and set the DISPLAY CONFIGURATION to a low resolution like 640×480.
  • Try turning off Fast Startup
    • This feature only works when you do a SHUTDOWN and then Boot. It doesn't effect a RESTART.
    • Go to Control panel, Power Options and select Choose What the Power Buttons Do on the left.
    • Then select Change Settings That are Currently Unavailable near the top center of screen...
    • Lower down on the window, uncheck Fast Startup.

Prevention

  • Disable bitmap caching for your RDP connections
  • Confirm RDP account has full administrative rights on remote system
  • Access the remote computer using consistent resolution – Full screen may help
  • Confirm both systems' video drivers are up to date

Resources

(Google it at Microsoft support sites; I have too low a reputation to post links)

  • Disable Bitmap Caching 2012
  • Hotfix for “Black screen during a Remote Assistance session in Windows Vista, in Windows Server 2008, in Windows 7, or in Windows Server 2008 R2”
  • The lock screen is black or blank and does not respond to keyboard or swipe actions in Windows 10 Technical Preview

Disable Bitmap Caching