Windows 7 alt-tab window disappears to back when aero peek is enabled

aeroaero-peekalt-tabwindows 7

There is a strange bug with Aero Peek and Alt-Tab where the Alt-Tab window itself is sent all of the way to the back, and is obscured by whatever window may be being previewed in front of it. While it still works for switching tabs, it's extremely annoying to not be able to see what other windows are there. One solution I've found is to just disable Aero Peek, but I like the Aero Peek feature when it works, and want it enabled.

Let me reiterate, because every response so far doesn't seem to understand this:

I do not want to turn off aero peek. Do not give me an answer saying that I can disable it in the performance options. I will downvote your answer. Read every word of my question before you answer anything that involves the word "disable".

Some users of Lenovo products have found that uninstalling the "Thinkvantage communications" VoIP suite fixes it for them, but my laptop is an HP, not a Lenovo. The only VoIP software I have installed is Skype, which I removed to see if it had something to do with VoIP, but that didn't have any effect. I had seen this issue before on my old laptop, but it usually went away after a while, and always after a reboot. On my new computer (HP dm4t) it always occurs, and is driving me nuts.

If anybody can actually pinpoint what the problem is and more importantly how to fix it, I will be extremely thankful.

alt-tab failure

Window being previewed is in front of the Alt-Tab window

Update:

The issue seems to have randomly resolved itself, at least for now. I have no idea what changed, since I haven't made any modifications to the system between when it was broken and when it started working. Attached is another screenshot of it working properly, with the alt-tab window in front of everything else. I'd still like to know what causes this if anybody can determine it.

alt-tab correct

Update 2:

And now it's broken again…

Update with Windows 7 SP1:

The problem still occurs with Service Pack 1 installed. Still no idea what may be causing it.

Best Answer

There seem to be two main (known) culprits here.

  1. Desktop Gadgets (sidebar.exe). If you can live without them, try disabling them:
    Right click desktop > select "View" > uncheck "Show desktop gadgets". This didn't work for me.
  2. Microsoft Intellipoint v8.1+. This was the solution that worked for me. It seems when they added support for the Microsoft Touch Mouse, the updated Intellipoint software introduced this bug. To fix it:
    Go to "Add or remove programs" and uninstall Microsoft Intellipoint. Instant fix, no reboot required.

If neither of those solutions work for you, I would try closing all open applications except for something innocuous, like notepad. Then open up your task manager and kill off suspicious processes one at a time until the problem is resolved. Obviously, make sure you don't kill a process that will destabilize your system. This could be a very tedious task.

This last post on the page in this thread helped me find the answer.