Windows 7 does not run chkdsk on reboot even when it is scheduled

bootchkdskwindows 7

I have a corrupt directory which I cannot delete and when I run CHKDSK in read only mode it finds errors (orphaned files). However since it is on my main (and only) partition I cannot run it with /R to fix the errors. It says it will schedule for a reboot and on my past machines this is exactly what happens when I restart my machine.

However now it seems when I restart it this does not happen and windows boots up on its merry way. Using fsutil I can see the volume dirty bit is still set.

Best Answer

  • Check this registry key

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

    default value for "bootexecute" should be

    autocheck autochk *

    if it is not, right click on it and select modify to change it.

    enter image description here

    If it still will not run, run it manually by booting from a W7 install DVD and run chkdsk from the command prompt, once you are at the WinRE command prompt type: chkdsk /r C:

    Use this guide to get to the command prompt by booting from the install or system repair disc. http://www.bleepingcomputer.com/tutorials/tutorial147.html

    If you do not have a W7 install disc (some PCs come with "recovery" discs and these won't work), see this article on how to make a windows system repair disc

    .

  • Related Question