Windows 7 Index Search does not work in Google Drive folder

google-drivewindows 7windows-search

I recently installed Google Drive on my Windows 7 laptop and began syncing all my files a few days ago. All was well until I needed to search for some documents in my local copy of Google Drive using Windows 7 Search feature.

Windows did not return any results at all. Weirdly, when I turned off Windows indexing for that folder, it began returning results.

I don't mind using windows search w/o the index but sometimes it takes too long to search (especially for keywords inside documents like Word and Excel). It's driving me nuts to the point where I have given up on Windows Search and switched to Google Drive's online search to look for files (not as convenient as I still have to go back go google drive in Windows to locate the folder). Any help appreciated!

Best Answer

OK, I hope this helps for people who are having problems with Windows 7 Search in Google Drive folder. After a few days of playing around, finally got windows search to work and best of all, search inside files(e.g. word, excel) works too!

  1. make sure security permissions for 3 users (specifically the SYSTEM group) are given FULL access to Google Folder. I'm not sure why my folder only gave my user account access. I realized this only after checking the other folders where index search was working.

FULL Control Security permissions for these 3 users

  1. Indexing is enabled for content. When Google Drive synced my files, it apparently did not set this attribute. The funny thing is that the folders were set but not the individual files inside. I'm not sure who to blame for this. So what I did was go to the Google drive folder properties, clicked on Advanced button, then unchecked "Allow files in this folder to have contents indexed in addition to file properties". After clicking all the OKs and confirming to do this to all folders and sub folders, go back to properties and enable the "Allow files in this folder..." so that it will propagate to all files inside.

Google drive Properties - Disable and enable the below checkbox for this property to copy to all files inside folder

Now Windows search is working for both normal file search and content searching. I'm not sure if this affects Google Drive in any way. But if you are reading this Google, please fix this in your app (unless this was done intentionally to force users to user Google Drive's online search :P).

Related Question