Windows 8.1 Update 1 Disk Usage 100%

hard drivememorywindows 8windows 8.1

Background Information / Computer Specs

I have a 14-inch Samsung Series 5 Ultra. Core i5 CPU, 750GB HDD, 8GB RAM, Intel HD Graphics 4000. I've had the computer for about 1.5 years with no major problems.

Problem

The issue appeared at the beginning of April this year, when I updated the OS from Windows 8.1 to Windows 8.1 Update 1 (not from 8 to 8.1). After being on continually (except for at night, when I put it on sleep mode) for about 48 hours, the disk usage as seen by Task Manager hits 100%. When this happens, everything from opening/closing applications to typing and even bringing up the start screen by pressing the Windows key becomes extremely slow. The only way to make the disk usage decrease is to restart the computer. Then the problem repeats. I've used my current laptop (as well as my previous laptops) this way — putting it on sleep mode at night and restarting it only when Windows needs to install updates — for a long time. So I know the 100% disk usage is not due to the way I use the computer.

The thing that causes the spike varies. Sometimes it's System, sometimes it's one of the various applications I installed (e.g. Chrome, Evernote, Spotify, Wunderlist, iTunes, etc.), and sometimes it's Antimalware Service Executable, etc.

Attempted Solutions

I think I tried almost every solution out there for this problem:

  • Running the check disk command (chkdsk /b /f /v /scan c:) from Admin Command Prompt
  • Running Windows Memory Diagnostic
  • Disabling Superfetch and Windows Search from services.msc
  • Running "Fix problems with Windows Update" from Control Panel –> Troubleshooting
  • Updating and rolling back the graphics driver (Intel HD 4000)
  • Disabling "Use hardware acceleration when available" from Chrome settings
  • Disabling Intel Rapid Storage Technology
  • Running the SFC /SCANNOW command as recommended here
  • Running a quick scan & a full scan from Windows Defender (no threats found)
  • Taking the hard drive out and putting it back
  • Refreshing the computer, from the Update and recovery –> Recovery option in Windows settings

NONE of the above worked for me. I was about to give up but then noticed that one of the main culprits of the disk usage spike, as shown in the "Disk Activity" section of the Resource Monitor, was C:\System (pagefile.sys). I googled around and found that one of the recommended solutions was to disable pagefile. I then went to Control Panel –> System and Security –> System –> Advanced system settings –> Advanced tab –> Performance settings –> Advanced tab –> "Change" under Virtual memory and discovered that the number for "Currently allocated" at the bottom was 1280MB, although the number for "Recommended" was 4533MB. I immediately changed it to 4533MB and checked my family members' computers to see what the numbers were like. All of theirs had a currently allocated space that was only slightly smaller than the recommended space. See screenshot below:

Virtual Memory Settings Page

This might fix the problem. I'll have to wait a couple more days.But if it doesn't, what in the world should I do next? I'm guessing the hard drive isn't failing because

  1. This computer is less than 2 years old; and
  2. Speccy says that the status of the HDD is good.

Update 5/27/2014

The "4533MB" solution did not work. I had to reboot the computer about 30 minutes ago because the disk usage again hit 100%. When I opened Resource Monitor the C:\System (pagefile.sys) again was shown to be the culprit. I have now disabled pagefile entirely via the same window shown above in the screenshot. The number for "currently allocated" is now 0MB. Will update again in a couple days, or if the problem occurs again, whichever comes sooner.

Update 6/4/2014 (Disabling page file force-restarts the computer)

So, between 5/27 and 5/30 I had to restart my computer for reasons related to various updates for third-party applications. I used my laptop (unplugged; on battery) on the night of 5/30 and then put it to sleep mode over night. When I woke up on 6/1 and pressed the power button, it first seemed like it was resuming from sleep but then rebooted the computer. This morning, the computer rebooted again. I guess disabling pagefile entirely took a toll on my RAM? I don't really know how to interpret this. For now I've enabled pagefile again.

Good News/Bad News Update 6/5/2014

I think I figured out the source of the problem – it's Superfetch. I think it has been Superfetch the whole time. It's true that I did include "disabling superfetch" from services.msc in the "tried solutions" list above. What I didn't realize at the time was that Superfetch restarts itself automatically shortly after I turn it off and disable it. So, the question I now have is: how do I permanently disable Superfetch?

Probably Final Update 6/8/2014

I think I figured it out. It probably was Superfetch the whole time. On the night of 6/5, after being on continually for a day, the disk usage started to spike again. I went to services.msc and stopped & disabled Superfetch. The disk usage got restored. About an hour later, I reopened services.msc, checked the status of Superfetch, and found that it was enabled again. I did this "disable-it-and-it-got-enabled-again" thing at least 8 more times, to no avail. I then googled "how to disable Superfetch permanently", and tried disabling Superfetch via 1) the administrator command prompt; 2) the registry; 3) services.msc, but nothing worked.

Then I went to this webpage and tried the "Disable Prefetch" option in the registry. I set both EnablePrefetcher and EnableSuperfetch to have the value data of 0. Superfetch was still running, but 3 days after I did this, my laptop has not seen a single disk spike. I put it to sleep mode overnight, and it did not force-restart in the morning.

For those of you having the same problem, please try the "Disable Prefetch" option as described on the webpage.

Best Answer

My advice is, even if everything appears ok (LAN, WIFI, Audio, etc) still replace all the generic drivers with your laptop specific ones. Especially HDD controllers, Chipset, etc. Solved my problem.

Background:

I had the same problem on my Lenovo G770. My Lenovo shipped with Windows 7 but I upgraded to 8.1 and after installation all seemed to go well except for this HDD activity which froze the disk for 15 to 30 seconds every 15 to 20 minutes. Unrelated; I had an 'Unknown Device' in Device manager, which, as it turned out was connected with Lenovo Energy Management. So I installed that from the Lenovo website and my Unknown device disappeared. But that led me to thinking that Windows 8.1 had installed all my devices without me downloading any drivers from the Lenovo website. Long story short, it appear my HDD problem was connected with generic drivers that Windows 8.1 had installed.