Windows 8 doesn’t automatically join Wi-Fi network if Ethernet connection is active; router prevents Ethernet devices from seeing some Wi-Fi devices

ethernetnetworkingrouterwindows 8wireless-networking

In Windows 7, my laptop would automatically join both an Ethernet network and the Wi-Fi network in my house (both going through the same router).

In Windows 8, if the Ethernet connection is present, it doesn't join the Wi-Fi network at all. The reason I noticed this is that if Wi-Fi isn't active, I don't see my AirPlay speakers. My wireless printer is also unavailable until I manually connect to Wi-Fi.

To recap: When I turn on my computer and it's connected to Ethernet, this is what my Win8 network sidebar looks like (Ethernet connected, but not Wi-Fi).

Screenshot - ethernet but no wi-fi

When I click the Caudil_FIOS Wi-Fi network, this is what I see (note that "Connect automatically" is always checked.)

Screenshot - connecting to wi-fi

After I click connect, it looks like this:

Screenshot - ethernet and wi-fi

Once I'm there, everything works great. In Windows 7, this all happened automatically on startup. In Windows 8, I have to do this dance manually every time I restart the computer. In fact, all it takes is for me to disconnect then reconnect Ethernet for it to disconnect again from Wi-Fi.

I would prefer for it to join both networks automatically on startup, the way it did in Windows 7. Is there a way to make this happen?

Alternatively – and it might make more sense to post this as a different question – is there a way to ensure that devices connected to Ethernet see the exact same thing as devices connected to Wi-Fi? In principle it doesn't make sense that my router is treating Ethernet and Wi-Fi as two separate networks, with no visibility between them.

Best Answer

The Windows 8 problem seems unsolvable at the moment for of lack of information.

All I have been able to find was that in Windows 8, Microsoft decided to rewrite the part relating to choosing a network, making it much more "intelligent" and automatic. In your case it is probably much too intelligent to work as you would like. It is probably forcing you to use only one network at a time.

As regarding the router, many threads mention the following solution for sharing between wired and wireless:

  1. Log into your router.
  2. Click the Advanced icon
  3. Click Yes
  4. Click on the IGMP Proxy
  5. Select Disable
  6. Click Apply

If this doesn't work, then the question is whether the wired and wireless networks are really separate or not. It seems like your router uses the IP segment addresses of 192.168.1.x, so the question is whether devices connected via both wired and wireless all get IP addresses with this prefix. If not, maybe using fixed IP addresses for wireless devices, all within this segment, and disabling the router function of DHCP Server, might fix this.

Related Question