Windows – Always Run PowerShell ISE As Admin

powershellpowershell-isewindows 10

I have Windows 10 and run some PowerShell commands through the Outlook COM object. This requires PowerShell to be running the same level of access (running as admin or user) as Outlook.

As I need PowerShell to be running as administrator for other pieces I set Outlook to always run as admin too, no problem. The issue is when I open the ISE I now can't access the Outlook objects.

There doesn't appear to be any way to set the ISE to always run as admin. The Compatibility tab is missing (though not on PowerShell itself?) and the registry keys in ...Windows NT\AppCompatibility did nothing. I'd disable UAC completely but of course it's not possible in Windows 10 without screwing over a bunch of other stuff.

Any ideas? And no I don't particularly feel like right clicking the icon each time as I often open scripts directly.

UPDATE: Outlook complains it can't index as admin and the ISE doesn't recognise my network drives as admin so the lesser of two evils is just run both as a user. Incidentally, the Compatibility tab has disappeared from the PowerShell exe now too, thanks Microsoft…

Best Answer

Here are 2 different options you can use to start ISE as admin:

  1. You can create/edit a shortcut to the powershell_ise.exe executable file and edit the properties for that shortcut to Run as Administrator.

enter image description here

  1. You can start PowerShell ISE as admin by Start-Process powershell_ise -verb RunAs.
Related Question