Windows – as a domain member, ‘run with administrative privileges’ always asks for hostname

administratorprivilegesrunaswindows 7

Since we run Windows 7-clients in our windows-server domain I have a specific use case that has become more inconvenient:

On the client-site, being logged-on as an user with restricted rights and having the user account control (UAC) activated on the highest level, you can run an application with administrative privileges by right-clicking onto it and choosing “Run as administrator”.

After that, a popup window is shown and asks for the username and password.

As a domain member you now have to enter your full hostname with a backslash following and the user name with administrative privileges (e.g. Administrator) in order to authenticate as local administrator.
On XP-machines you simply had to type in “Administrator” for the username.

That makes administration more inconvenient if you run various Windows-7 clients in a company, because you always have to lookup the hostname for the machine on which you want to run something with administrative privileges.

Is there a registry setting or a good workaround that lets you authenticate as administrator without having to enter the hostname for the machine, but not using tools like "RunAsSPC" or "Steel RunAs"?

Best Answer

When you want to authenticate to the local computer, you can use a dot instead of the hostname. This doesn't make the issue go away entirely, but at least it prevents you from having to look up hostnames since . works everywhere.

Username: .\Administrator
Password: *******

In certain contexts, localhost will work instead. I haven't yet found a situation where either . or localhost doesn't work, but I'm sure there is one somewhere.