Windows – Can’t change or set password in Windows 7

passwordsSecuritywindows 7

I'm trying to set up a new user in a Win7Pro computer. The computer has HP ProtectTools enabled.

I cannot set the password from within HP ProtectTools or the User Accounts control panel, when logged in either as myself (administrator) or as the new user. I also cannot use net user <newuser> <newpasswd> from an admin-level command prompt, nor can I use the Local Users and Groups pane of the Computer Management dialog.

Whenever I try to do set the password in any of these ways, the dialog or command prompt freezes. For Control Panel and ProtectTools, the dialog turns 50% white, and mouse starts spinning. For cmd and Computer Management, I get the helpmsg 2245:

The password does not meet the password policy requirements. Check the minimum password length, password complexity and password history requirements.

However, the Local Security Policy administrative tools applet has Password Policy set to:

  • Enforce password history: 0 passwords remembered
  • Maximum password age: 0
  • Minimum password age: 0 days
  • Minimum password length: 0 characters
  • Password must meet complexity requirements: Disabled
  • Store passwords using reversible encryption: Disabled

In short, there should be no requirements.

Why do I get this message, and how can I resolve it?

Best Answer

I've just taken a look at the Password Policy on my computer (Win 7 Ult 64-bit) and even though I am never prompted to change my password, the value of Maximum password age is set to 42 (default). I know that when it is set to 0, a user's password will never expire, so you should be having no problems setting a password.

I've also tried with the value set to 0 and I haven't been able to replicate your problem. You could try changing the value to something other than 0 and then changing it back to 0 and see if that helps. Or you could change the value to an x number of days and tick the Password never expires option when you create a user to bypass that setting.

Finally, you could try setting a password that meets the complexity requirements as the Group Policy Object may not be applying the settings properly.